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Introduction

This document describes the process for editing and customizing the Identity Finder MSI using tools
freely available from Microsoft. Included are instructions for adding license information to the
installation package, changing the default settings, and performing other advanced tasks to change the
way that Identity Finder is deployed in the target environment. Before beginning to edit the MSI, all of
the tools listed below must be installed and functional.

While this guide does not address every possible configuration change available for MSI packages, it
covers the most commonly addressed changes relating to deploying Identity Finder. Editing of MSI
packages is solely the responsibility of each individual customer. Only limited support for MSI
customizations is available, relating specifically to any issues with the steps and instructions included in
this guide. Edits beyond this guide can be made, but are the responsibility of the customer and cannot
be supported by Identity Finder. Customizations beyond this guide, or any customers requiring
continued creation and maintenance of customized installation packages, may contact Identity Finder
and inquire about our professional services offerings.

Copyright: This document is the intellectual property of Identity Finder, LLC. Permission is granted for
this material to be shared for non-commercial, educational purposes, provided that this copyright
statement appears on the reproduced materials and notice is given that the copying is by permission of
the author. To disseminate otherwise or to republish requires written permission from the author.

Required Tools

Description: All of the tools listed below must be installed and the “makecab.exe” utility and the SDK
bin directory must be in the PATH environment variable, enabling them to be run from the command
prompt in any directory. If these files are missing, the instructions below will not work correctly.

1. Makecab.exe — A tool for creating Microsoft cabinet files.
Information and Download: http://support.microsoft.com/kb/310618
Note: makecab.exe is included with Windows XP, Windows 2003 Server, Windows Vista, and
Windows Server 2008

2. Microsoft Platform SDK — The Microsoft® Windows® SDK is a set of tools, code samples,
documentation, compilers, headers, and libraries that developers can use to create applications that
run on Microsoft Windows operating systems using native (Win32) or managed (.NET Framework)
programming models.

Download: http://msdn.microsoft.com/en-us/windows/bb980924.aspx
Note: In most cases the newest version of the SDK is appropriate; however please consult the
above web page for instructions on downloading and installing the SDK.

3. Orca - Tool to view and edit MSI’s.
Information: http://msdn2.microsoft.com/en-us/library/aa370557(VS.85).aspx
Note: The Orca installer is part of the SDK installation, however it must be installed separately after
the SDK is installed.
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Tool Installation

Description: The SDK and Orca installation require additional steps beyond the normal SDK install
process. These extra steps detail the installation of Orca and the process for ensuring that the SDK
applications can be easily accessed by the command line.

1.

Identify the SDK installation directory, and locate the bin directory containing SDK executables. If a
custom directory is selected when installing the Platform SDK, please use that directory, otherwise
the defaults are:

Server 2008 SDK - C:\Program Files\Microsoft SDKs\Windows\v6.1\bin

Vista SDK - C:\Program Files\Microsoft SDKs\Windows\v6.0\

Server 2003 - C:\Program Files\Microsoft Platform SDK for Windows Server 2003 R2\bin

2. Add the SDK bin directory to the computers PATH environment variable.

a. Windows XP/Server 2003:

i. Right click on My Computer and select Properties.
ii. Navigate to the “Advanced” tab.
iii. Select the “Environment Variables” button.
iv. Follow directions beginning with step “C” below.
Windows Vista/Server 2008:
i. Right click on My Computer and select Properties.
ii. Click on the “Advanced System Settings” option.
iii. Ensure that the “Advanced” tab is visible.
iv. Select the “Environment Variables” button.
In the Environment Variables window, under the “System Variables” section, find the
variable named “Path”.
Select “Path” and click the “Edit” button.

. At the end of the value field, add a semi-colon and then the SDK bin directory identified in

step 1 above. For example, if the Server 2008 SDK was installed and the current path value
is

“%%SystemRoot%\system32;%SystemRo0t%;%SystemRoot%\System32\Wbem”,

the new value would be
“9%SystemRoot%\system32;%SystemR00t%;%SystemRoot%\System32\Wbem;C:\Program
Files\Microsoft SDKs\Windows\v6.1\bin”

Note: Values should be entered without the “’ quotes.

Click the OK button and dismiss all other dialogs and windows.

Restart the computer.

identity
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Manually Extracting the MSI

Description: This section describes how to obtain the MSI from the executable available on the Identity
Finder web site.

NOTE: If a license file is to be added to the MSI, the MSI should not be extracted manually. Instead,
follow the instructions below for adding a license file to the MSI.

1. Download the executable from the ldentity Finder web site:
http://www.identityfinder.com/Enterprise/index.html

2. Save the file locally and note the path to which it was saved.

3. Open a command prompt by clicking Start -> Run, entering “cmd” (without the quotes), and pressing
Enter.

4. Navigate to the download directory using the “cd” command.

5. Execute the following command line:

IdentityFinder4Setup.exe /MSIDIR=.

6. The above line will extract the MSI, IdentityFinder4Setup.msi to the download directory. To see the
folder in Windows Explorer, type the following:

explorer .

O
identity Copyright © 2008 Identity Finder, LLC Xy



http://www.identityfinder.com/Enterprise/index.html

Using a Batch Script to Add a License File or Activation Code

Description: This section describes using a batch script provided by Identity Finder to update the
Identity Finder MSI package with a license file. The command script is a generic solution that should
work for most installations; however, the script can only add a license file to the installation package. If
any other changes are required for the installation package, then other manual methods must be used.

1. Copy all of the relevant files into a new working directory and prepare them for processing.
a. Create a new directory for processing named “C:\IDF_Install”.
b. Copy into the “C:\IDF_Install” directory the following files:
I. IdentityFinder4Setup.exe — This is the setup executable downloaded from the
Identity Finder web site (http://www.identityfinder.com/Enterprise/index.html)

ii. ldentityFinder.lic — This is the license file provided to the organization with an
enterprise license. If an activation key is being used, this file is not used.

ii. Activation.txt — This is the text file containing the activation code. To create this file,
open Notepad and paste the activation code provided after purchase. Save the file
and exit. If a license file is being used, this file is not used.

iv. FileLine.txt — A text file containing additional information to be appended to the File
table of the MSI, provided with this documentation.

v. MediaLine.txt — A text file containing additional information to be appended to the
Media table of the MSI, provided with this documentation.

vi. lictomsi.cmd — A command script written by Identity Finder to automate the process
of adding only a license file to the Identity Finder MSI installation package.

c. Open a command prompt and navigate to the “C:\IDF_Install” directory.
2. Run the included command script that will automatically extract and update the MSI file with the
license file or activation code in the same directory by issuing the following command:

License File:
C:\IDF Install> lictomsi.cmd

Activation Code:
C:\IDF Install> acttomsi.cmd

3. When the lictomsi.cmd or acttomsi.cmd command script finishes it will report the final outcome of
the operation and will indicate whether or not the update was successful. If the update happened
correctly the last line of output should read, “MSI Update complete.” If any errors occurred, they
should be listed in the command window. If this happens, please copy and paste them into an
email to support@identityfinder.com

4. If the update was successful, the directory “C:\IDF_Install” will contain the file
“IdentityFinder4Setup.msi,” that now includes the license file. Install this package on a test system
and verify that the license file installs correctly.
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Manually Adding a License File

Description: This section details the steps required to manually add a license file to the Identity Finder
MSI installation package.

1. Copy all of the relevant files into a new working directory and prepare them for processing.
a. Create a new directory for processing named “C:\IDF_Install”.
b. Copy into the “C:\IDF_Install” directory the following files:
i. ldentityFinder4Setup.exe — This is the setup executable downloaded from the
Identity Finder web site (http://www.identityfinder.com/Enterprise/index.html)
ii. ldentityFinder.lic — This is the license file provided to the organization with an
enterprise license.
iii. File.idt — A text file containing information to be entered into the File table of the MSI,
provided with this documentation.
iv. Media.idt — A text file containing information to be entered into the Media table of the
MSI, provided with this documentation.
c. Open a command prompt and navigate to the “C:\IDF_Install” directory.
d. Extract the MSI from the installer by issuing the following command at the command prompt:

C:\IDF Install> IdentityFinder4Setup.exe /MSIDIR=.

e. Review the files in the directory and there should now be a file named:
IdentityFinder4Setup.msi

2. Update the File and Media tables in the IdentityFinder4Setup.msi package file to reflect the fact that
a license file will be added to the MSI.

a. Open the MSI file in Orca by either launching Orca (Start -> Program Files -> Orca) and
opening the MSI file “C:\IDF_Install\ IdentityFinder4Setup.msi”, or right click on the MSI
package file (IdentityFinder4Setup.msi) in Windows Explorer and select “Edit with Orca”.

b. Using Orca, update the File and Media tables with the information provided in the File.idt
and Media.idt files.

i. Select the Tables - Import Tables... menu item

—~& IdentityFinderEnterpriseSetup.msi - OFc - | Dlﬂ
File Edit | Tables Tramsform  Tools  Wiew Help
0|z | &dd Table. .. Chrl+T bJ m T,

————- add Custom Table...
| Tables [pop 7able

Aeotior

AdminE add Raw,.., CEr| R

Lawint  Crop Rowis)

AdvtEx

Appsez  Export Tables...
Einary [ e ==

CheckE
C oLp oL ,|:I,|j]|_|5t Schema, ., .

Control

ControlCondition
ControlEwent

CreateFolder ;I

Tablzs: 39 [ column is selected. =

ii. Navigate to the “C:\IDF_Install” directory. Hold down the CTRL key and click once
on each file for “File.idt” and “Menu.idt” to select both files:
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ii. Click the “Open” button.

iv. Click OK on the next dialog. This dialog shows the summary of the actions and will
list the File and Media tables and signify that the action is Merge for both.

mport x|
Table | action | | oK, |

File berge

Media Merge Canicel |
Browse... |

£ [mport
" Beplace
) Wemge
= Skip

v. Verify that the Media table has been imported correctly by comparing it to this
screenshot:

e —————
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Vi.

~# IdentityFinderEnterpriseSetup.msi - Orca

File Edit

Tables

Transform  Tools

Wiew Help

=10 x|

D& &[]

2| = e | E

|

Tables I;l Diskld I LastSequence | DiskPrompt Cabinet I '1.F| SI
InstaluIseq. .. 1 10 Disk. 1 #IDF.cab
LaunchCondi... 2 1 Disk 2 #lic.cab
ListBio

identityfinder

MsiFileHash
Property
RadioButton LI
Tables: 41 [Media - 2 rows Mo calurn is selecked, oz
Verify that the File table has been imported correctly by comparing it to this
screenshot:
~# IdentityFinderEnterpriseSetup.msi - Orca - |EI|1|
File Edit Tables Transform Tools  MWiew Help
Dl #[E=|e2] =] =2
Tables [~] File | compon... | FileName FileSi... | Yer... | Lan... | Attri... | Se... |
EventMapping APPEXE MainExecutable idf.exe|ldentityFinder . exe 22121472 4.0.0.0 1033 512 1
Feature CRYPT MainExecutable cryptopp.dil|crvptopp.dl (1060864  5.2,3.0 1033 512 z
FeatureCaom. .. IDE MainExecutable idfdb.dat|identitydb.dat 415061 51z 3
IDFHELF  MainExecutable idf.chm|IdentityFinder.chin 11955335 51z 4
Icon IDFOLL MainExecutable idf.dll|IdentityFinder. di 434176 26,08 1033 512 5
InstallExecut. .. IDFHOLL  MainExecutable idfhelp, dlljidfhelp.dil 1045126 6.84.0 1033 5iz ]
InstallllSeq... IDFROLL  MainExecutable idfreprt.dll|idfreport.dil 214018 1.2.27... 1033,7 512 7
LaunchCondi, .. IDFSHOLL MainExecutable idfshesxt.dl|idfshext.dll 102400 1.0.0.0 1033 512 g
ListBiox IDFSEFPDLL IDFService idfEp. dll[idFEndpaint, dll 0624 1.000,0 2045 51z 9
Media IDFSEPEXE IDFService idfEp.exe|idfEndpoint.exe 5762045  1.0.0.0 2043 51z 10
MsiFileHash IDFLIC MainExecutable idf.lic)identitvfinder . lic a05 51z 11
Froperty LI
Tables: 41 |File: - 11 rows Mo colurmm is selected. v
s
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vii. Save the MSI file by selecting the File > Save menu:
~# IdentityFinderEnterpriseSetup.m - | Ellil
| File Edit Tables Transform Tools Wiew Help

Tl CErl+M
Chrl+C
CErl+5

Save As...

itahle Crypti
1table idfdh.
Close itahle idf.cl

1 IdentitvFinderEnterpriseSetup. msi jrable :i'df : d
itable idfhe!

2 IdentityFinderEnterpriseSetup, msi table idfrep
3 IdentityFinderEnterpriseSetup, msi tahle idE. 1-
4 IdentityFinderEnterpriseSetup, msi

Sawe Transformed &8s, .,

Exit
Media ;I | F I I _pl
Tables: 39 |I_=|r'-.||:u column is selected, i

viii. Chose the File & Exit menu and close Orca:
~* IdentityFinderEnterpriseSetup.m i [m] B
Fil= Edit Tables Transform Tools Wiew Help

[T CErl+-M ml |
CIpen. .. Chrl+0 ==

Save EErIH-S 5 FilelN
itable 1idf.ex

itahle crypte
itahle idfdb.
Close itable idf.cl

1 IdentityFinderEnterpriseSetup, msi jeahle }df' d'_
itahle idfhe!

z Ident!tnynderEnterprfseﬁetup.ms! table idfrep
3 IdentityFinderEnterpriseSetup, msi tahle idf. 1-
4 IdentityFinderEnterpriseSetup. msi

Media LI 4

Tables: 39 F [Mo column is selected,

Save As...
Save Transformed As, .,

i
4

3. Create a cabinet (.cab) file to hold the license file and then add that cabinet file to the MSI package.

a.

b.
c.

Go back to the command prompt window where the prompt should be at the directory
“C:\IDF_Install”.

Make sure that the license file is in the directory and is named “identityfinder.lic”.
Copy the existing file to the name IDFLIC by issuing the following command:

C:\IDF Install> copy identityfinder.lic IDFLIC

Check the directory and ensure there is now a file named “IDFLIC”.

Create the cabinet (.cab) file by using the makecab.exe program, buy issuing the following
command:

C:\IDF Install> makecab.exe IDFLIC lic.cab

identity
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10

The makecab program should run and return to the command prompt. If there are no errors
it should output a final line that looks similar to this: “100.00% [flushing current folder]”.
Verify that there is a file named “lic.cab” in the directory and that it is all lower case.

Add the “lic.cab” file to the IdentityFinder4Setup.msi using the msidb.exe application by
issuing the following command:

C:\IDF Install> msidb.exe -d IdentityFinder4Setup.msi -a lic.cab

The msidb.exe program will run silently in the background. If no errors occur, the program
will exit without reporting any information and return to the command prompt. If any errors
occur, a dialog box should come up and report the error conditions.

identity
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Manually Adding Any File

Description: These instructions describe the process for adding arbitrary files to an existing MSI
package. To add files to an MSI, the target files must be added to a cabinet (.cab) file, the MSI tables
must be edited to reflect the existence of the new files and their intended install locations, and the
cabinet (.cab) file must be added to the data stream of the MSI package.

1. Locate the files to be added to the MSI package and create a cabinet (.cab) file using the
“makecab.exe” program.

a.

2o

Determine an appropriate naming scheme for each file. The name of each file that is added
into the cabinet (.cab) file is required for use when editing the MSI tables (in subsequent
steps), so a naming scheme where the file names are given short, descriptive names makes
it easier to add these items into the MSI tables.

Once a naming scheme is determined, copy all existing files into their new names. For
example, if a file named, “configuration.ini,” is being added, it would make sense to rename
this to, “CFGINI” or a similar name before adding it to the cabinet (.cab) file.

Copy all files into a directory, such as C:\temp.

Create the cabinet (.cab) file using makecab.exe program. For help, open a command
prompt and type “makecab” (without the quotes). Here is an example of making a cab with a
single file (using the file name example from (b) above):

C:\temp> makecab CFGINI config.cab

2. Edit the MSI tables to reflect the new files that will be installed.

a.

b.

Copy the MSI package to be edited into the same directory where the cabinet (config.cab)
file was created, e.g. C:\temp. In this example, the MSI package is Application.msi
Launch Orca (Start -> Program Files -> Orca) and open the MSI file Application.msi, or right
click on the MSI package file (Application.msi) in Windows Explorer and select “Edit with
Orca”.
The first table to review is the “Component” table. Click on this and look at the components
already defined in the MSI. Each component is linked to a feature via the
“FeatureComponents” table, and each feature is described for the graphical interface (the
dialog where the user selects what features they do or do not want to install) in the “Feature”
table. Looking in the feature table at items with a Level of 1, 2, or 3 will show the items that
are likely always installed. This view may help narrow down the feature in which the new file
will be added. The features and components of an MSI differ for every MSI, so it will be
necessary to decide in which feature the new files should be included. Once the desired
feature is determined, view the “FeatureComponents” table to see the list of components
that are installed for that feature. Determine from that component list with which individual
component the file should be associated. In this example, the component name is,
“MainExecutable”.
Open the “File” table to view all of the existing files installed by the MSI. Add a new row
(Tables > Add Row...) and complete each of the columns in the DATA lines, as follows. In
this example, the file names configured in Step 1 above will be used.
i. File: This is the name of the corresponding file in the cabinet (.cab) file that was
created.
DATA: CFGINI
ii. Component_: This is the component that was determined above in step (2c).
DATA: MainExecutable
iii. FileName: This is the target name of the file. Both a short (8.3 MSDOS) and long file
name must be provided and separated by the pipe | character as shown below.
DATA: config.inijconfiguration.ini

identity
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FileSize: The number of bytes in the file size. This can be obtained by right-clicking
on the original file in Windows Explorer and choosing Properties and then reading
the size in bytes of the file. For this example, it is 1024 bytes (1 K).

DATA: 1024

Version: This field is for version numbers of DLL’s and executables. Since .ini files
are not DLL’s or executables this field is left blank. If a DLL or executable were
being added, this field would be completed with the target files 4 digit version in the
form 1.2.3.4

Language: This field is only for DLL’s and executables and lists the supported
language codes. 1033 is English. For this example, this will be left blank as it does
not apply to .ini files.

Attribute: This field defines the attributes for the file that determines how the MSI
handles the file. The attribute number will vary by MSI, but 512 is a standard default.
This value requires the file to be installed and if that fails, the installation is stopped
and a rollback occurs. Check with the other files in the MSI to determine their
attribute number. If all of the other files are using the same number, then that
number should be used.

DATA: 512

Sequence: This field holds the sequence number that will be referenced later. The
sequence number must be higher than the highest existing sequence number used
by other files. For example, if there are 10 files with numbers 1 through 10, add an
11 as the next sequence number. The data value should be a number that is exactly
one greater than the highest existing number. For this example, the highest existing
number is 10.

DATA: 11

Repeat step (2d) for each file that is included in the cabinet (.cab) file. In this example, only
one file is added to the cabinet file (config.cab); however, it is possible to add as many files
as necessary to a cabinet file and the MSI.

Once the file table and features (if edited) are configured, the last step is to configure the
“‘Media” table. The “Media” table defines how to access the cabinet (.cab) file that was
created in step 1 and will be added to the MSI package in step 3. Add a new row to the
“Media” table (Tables - Add Row...) and complete each of the columns in the DATA lines,
as follows. In this example, the file names configured in Step 1 above will be used.

Diskld — This is an internal marker for the disk number that is used by the MSI. Keep
incrementing this number for each cab file that is added. If there is only one cab file
already defined and its id is 1, then add a 2. In this example, the Application.msi
package has 1 existing cab file.

DATA: 2

LastSequence — This is the last sequence number used by the msi “File” table in this
cab. This number should correspond to the sequence number added in step (2d-
viii).

DATA: 11

DiskPrompt — If the cab file can not be found in the MSI package, the user will be
asked to insert media or locate the cab file. Since the cab file will be inserted into the
MSI, this is not necessary and may be set to any name. A general convention is to
use the number from the Diskld column.

DATA: Disk 2

Cabinet — This indicates the name of the cabinet file that will be added to the MSI
package below in step 3. This name is case sensitive and must be preceded by a #
pound sign.

DATA: #config.cab

VolumeLabel — This is to set the VolumeLabel of a disk expected to contain the
relevant cabinet (.cab) files. This is not necessary when the cabinet files are
embedded in the MSI, so it should be left blank.

identity
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vi. Source — This field is only used for patching and should otherwise be left blank.

3. Add the cabinet file into the data stream of the MSI package.

a.

b.

Ensure that all files are in the working directory and open a command prompt. For this
example, the directory is “C:\temp” and the files are Application.msi and config.cab.

Use the msidb.exe program to add the cabinet file (config.cab) to the msi (Application.msi)
using the following command:

C:\temp> msidb.exe -d Application.msi —-a config.cab

The msidb.exe program will run silently in the background. If no errors occur, the program
will exit without reporting any information and return to the command prompt. If any errors
occur, a dialog box should come up and report the error conditions.

4. Double click on the msi (Application.msi) and ensure that all the files are installed to the correct
locations.

identity
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Adding Custom Registry Settings

Description: These instructions detail the process for editing the MSI to add custom registry settings to
be applied to a target system during installation.

MSI Registry Table Column Definitions:

These column definitions provide required information about the registry table within the MSI that
requires editing. Detailed documentation about the registry table is available from Microsoft's MSDN
web site: http://msdn.microsoft.com/en-us/library/aa371168.aspx

The column definitions are:

Registry — A field containing a unique name to identify the registry setting. This field can
contain any name as long as it is unique and does not contain special characters.
Maximum Field Length: 72 characters

Root — Indicates the registry key’s associated root. Normal values are 1
(HKEY_CURRENT_USER) or 2 (HKEY_LOCAL_MACHINE).

Key — Indicates the path to the registry key. This field can contain any characters allowed in a
registry path.
Maximum Field Length: 255 characters

Name — Indicates the value name. This field can contain any characters allowed in a registry
value name.
Maximum Field Length: 255 characters

Value — A field that contains the value of the registry key. The actual contents of this field vary
depending on the type of value desired. Each different value type has a special way of being
entered into the MSI field, as follows:

o Binary Value (REG_BINARY) — Binary values are stored as a series of hexadecimal byte
pairs. To signify a binary value, the value field must start with “#x”. To specify the byte
stream 0x11, Ox3F, Ox4A, 0x6C enter the following into the value field:

#x113F4A6C

o Expandable String Value (REG_EXPAND_SZ) — Expandable strings must be preceded by a
“#%” in the value column. To specify an expandable string with a value of
PROGRAMFILES, enter the following the value field:

“%PROGRAMFILES

o DWORD Value (REG_DWORD) — Integer (DWORD) values are the most common in the
registry and must be entered in decimal form in the value field starting with a # sign. In
many cases, the Identity Finder settings documentation will reference a hexadecimal value.
Hexadecimal values can be converted to decimal values using the windows calculator (Start
-> Run -> calc.exe, View -> Scientific) or using many other freely available conversion tools.
To specify a value of OxXFFFFFFFF, convert it to the decimal value 4294967295, and enter
the following into the value field:

#4294967295

To specify the number 1, enter the following into the value field:
#1
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o Multi-String Values (REG_MULTI_SZ) — Multi-string values are entered by separating each
string value with the sequence “[~]". If a multi-string is required but it only contains one
value, there must be a “[~]” sequence at the end of the value field. To specify a custom
include list that contains only the directory “C:\data”, enter the following into the value field:

C:\data[~]

To specify the two values, “C:\data” and, “C:\newdata”, enter the following into the value

field:

C:\data[~]C:\newdata

o String Value (REG_SZ) — A string value is entered without any special characters. To

specify a log name of, “C:\data\log.txt”, enter the following into the value field:

C:\data\log.txt

e Component_ - Indicates the install component associated with the key. For simplicity, this
should be either MainHKCUItems for any item stored under HKEY_CURRENT_USER or
MainHKLMItems for any item stored under HKEY_LOCAL_MACHINE. These component
definitions are unique to the Identity Finder MSI. If one of these is not used, the registry setting

will not be installed by the MSI.

Locate the MSI, either as the output of adding a license file to the installer as described above in
Using a Batch Script to Add a License File or Manually Adding a License File, or by extracting the

MSI manually as described in Manually Extracting the MSI.

Right click on the MSI in Windows Explorer and choose “Edit in Orca”. Alternatively, open Orca and
go to the File > Open menu and locate the MSI.

Select the Registry table in the table list on the left to display its contents on the right:

-~ # IdentityFinderEnterpriseSetup.msi - Orca ;|g|5|
File Edit Tables Transform Tools Wew Help

Df e #[e=(elF] #]=]e| ==

Tables I;I Registry | R... | Key | Marne | Wallie Component_ |;

ListBo hkcukeyCEmpty 1 Softwarel[ShortappMame] CEmpty

Media hklmRernkey 2 Softwarel[ShortApptarie] RemovedldUuninstalStuff

MsiFileHash hkrukey 1 Softwarel[ShortappMarie] MainHKCUTterms

Property hkIrnkesy z Software! [ShortapphMarme] MainHELMItems

RadinButton uninstkey 1 Softwarel[Shortapptarie] StartShortouts

ReglLocatar desktopkey 1 Software!, [ShortApphare] DesktopShortouts

Reqistry fakiey 0 Jidf FileAszociation

RemoveFie A1 1 Softwarel[ShortappMameTy... enable_aU_TFN #1 Intl_&UTFN e

RemoveRegistry LK1 1 Softwarel [Shortappiame]y.,. enable_UK_NING #1 Intl_UKMING

Shortout K3 1 Softwarel[ShartappMameTy... enable_UK_NHS #1 Intl_LKMNHS

SignatLre a1 1 Software! [ShortappMarme ... enable_Canada_SIM #1 Intl_CASIM

TextStyle UpCheckReg 1 Softwarel[ShortappMameT,... doversionCheck #0 UpdateCheck

U Text Stody 1 Software!, [ShortappMarne ... showiizard #0 StartAdvanced

Uparade WASRegl 1 Softwarel [Shortapptarme]y.,. doDriversLicensey s #1 CWAS

_Walidation | | P3Req 1 Softwarel[ShortappMameTy... requireStrongPasswords #3 P3

| ZIP256Reg 1 Softwarel [ShortappMameTy... alwaysUseZipEncryplion #1 CZIPZS6 ;l
Tables: 39 [Registry - 31 rows Mo colurnn is selected, v
s
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4. Add a new registry setting, by choosing the menu Tables - Add Row:

—~* IdentityFinderEnterpriseSetup.msi - Drca ;|g|5|

Fil= Edit | Tables Tramsform Tools  Wiew Help

n =0 add Table. .. Chrl+T El ﬁ &,
————- Add Custom Table... —

Tables Crop Table. .. I I R... I Kexy =l
L?aur‘u:hl el Row, . CHlsR Empty 1 Softveare’ [Shart
ListBox Drop Raw(s) ke 2 Software’, [Short
Media 1 Software’ [Short
MsiFilgH ~ Export Tables... 2 Software’, [Short
Propert: Import Tables... 0 1 Software!, [Short
RadicBL  Adjust Schema. .. ey 1 Softweare’ [Short=
ReglLocatar fakiey 0 Jidf
Registry &1 1 Software’ [Short
RernoveFile LK1 1 Softvarel [Shart
RermoveRegistry LIk32 1 Software!, [Short
Shortcut cal 1 Software’ [Shart
Sighature UnCheckReg 1 Softwearel [Shart
TextStyle Stady 1 Softwarel [Short
LI Text b WasRegl 1 Softweare’ [Short «
Upgrade jid || KN 4

Tables; 39 |Regist |I"-.I|:| column is selected. v

5. The Add Row dialog will be displayed:

x

Mame | " alue | -

(EJ Feqgiztny

F oot

ke

M ame

"W ale

Compaonent ;I

— Colurnn
Registy - String[72], Required

k. I Cancel

6. Complete each field according with the desired values. For example, the use of AnyFind Password
searching for all users on a computer will be disabled. This setting has the following registry
information:

Key: HKEY_ LOCAL_MACHINE\Software\ldentity Finder\Client\Password
Value Name: EnableAnyFind

Value Type: REG_DWORD

Value Data: 0
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The Registry Table columns will have the following values:

x

Marmne Yalue =
(EJ Registry

dizableP*/Search

Root 2

K.y Softwaretldentity Finder\Client'Pazsword

M ame E nablednyFind

Walue #0 .

Compornent | MainHELMIbemns LI
— Calumnn

Reqizty - String[72], Reguired

dizableP'wSearch

k. I Cancel

The values are:

Registry: disablePWSearch

Root: 2

Key: Software\ldentity Finder\Client\Password
Name: EnableAnyFind

Value: #0

Component_: MainHKLMItems

O O O O O O

7. Repeat the steps above to add all desired registry keys.

s
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8. Save the MSI using the File > Save menu:

—~* IdentityFinderEnterpriseSetup.msi - Drca ;|g|5|
IE Edit Tables Transform Tools  Wiew Help
e CErl+-M = | =
CIpEM.. . Chrl+0 IH =
5 Ctrl+5 I [ R | ke -]
Save As... 2 Softveare’ [Shart
Save Transformed fs, ., 0 Jidf
Close 0 idf
1 IdentityFinderEnkerpriseSetup. msi 0 IdentityFinder. Re
& IdentityFinderEnterpriseSetup. msi 0 IdentityFinder . Re
3 IdentityFinderEnterpriseSetup, msi a IdentityFinder.Re
4 IdentityFinderEnterpriseSetup, msi 0 IdentityFinder.Re
Exit 1 Softwarel[Shaort
[ REMOvere o= 1 Softvarel [Shart
RermoveRegistry Lik4 1 Software!, [Short
Shortcut caz 1 Software’ [Shart
Sighature WASREgZ 1 Softwearel [Shart
TextStyle shelExtCommand 0 Directory’shell, [L—
LI Text disablePSearch E;|:|ft'-.-'-.-'are".,IdEﬂti -
Lipgrade fad || KN I
Tables: 39 [regist |Roat - Shart v

9. Export the Registry Table to a text file in case the MSI gets accidentally deleted or if support help is
required.
a. Choose the Tables - Export Tables option:

~ ¥ IdentityFinderEnterpriseSetup.msi - Orca =100 x|
File Edit | Tables Transform Tools Wiew Help
Ol | add Table... CErl+T El ﬁr .

————- ndd Custom Table...

Tables  Drop Table... | | R... | Key ]
Lauirich M 2 Softwarel [Short

i add Row, Chrl+R i

ListBox Drop Raw(s) 0 Jdf
Media 1 0 Jddf
SEa=a  Export Tables... C 0 IdentityFinder.Re
Propert Lmpeile TESEE. il 0 IdentityFinder.Re
RadioBL  Adjust Schema... gl 0 IdentityFinder . Re
ReglLocator rermovefaz 0 IdentityFinder.Re
Fegistry ALIZ 1 Software’ [Short
RermoveFie Lik2 1 Softwarel [Short
RermoveRegistry ) 1 Softveare’ [Shart
Shortout CAZ2 1 Software’, [Short
Signature WaASReg? 1 Software’ [Short
TextStyle shellExtComrmmand 0 Directaryshell IL—
U Text T | disablePwSearch u Software! Identitf
Upgrade fad || KN

Tables: 39 |Reqist |Ront - Shart i
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b. Select the appropriate output directory by clicking the Browse button, and selecting only the
Registry table checkbox:

Export Tables x|

Cluatput Directaorny:
=

¥ Use Lang File Mames.

Tables:
[IkziFileHash

a|  Selectal |
Clear Al |
Ireeert |

[|RemoveRegisty J
1S hortcut
[1Signature

c. Click OK. A file named Registry.idt will be created in the selected directory (the example
above specifies C:\).

s
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Adding a Scheduled Task

Description: This section describes the use of operating system programs to automatically schedule a
task when user credentials (a username and password) are programmed into the MSI.

NOTE: Task Scheduling on Windows requires a valid user name and password combination
(credentials). Because the scheduled task must be updated when a password is changed, it is
recommended that only service accounts that have a password that cannot be changed or the local
system account is used. If the local system account is used, Identity Finder will not have network
access to save results to a network location nor will it have access to search remote systems over the
network.

1. Locate the files required to add a scheduled task creation action to the MSI. The zip file that
contains this document also contains a folder named “MSI - Task Scheduler,” that contains the
following files:

AppSearch.idt

Component.idt

CustomAction.idt

DrLocator.idt

FeatureComponents.idt

InstallExecuteSequence.idt

Registry.idt

Signature.idt

O O O O O O OO0

2. Determine how and when the task should be run and what credentials will be used. The ldentity
Finder Administrator’'s Guide describes the command line options for configuring and launching the
task via the registry or a configuration (*.xml) file. There are multiple ways to configure a scheduled
task, for example:

a. Some customers run the search once a week or once a month as the local system account
and read settings from the registry.

b. Some customers configure the search with a service account where the settings and results
are read from and saved to a secured network location.

c. Some customers configure the clients to report to the Monitoring Console so that all results
are stored in a centralized reporting interface. This is possible even if an account without
network credentials is used.

3. Edit the CustomAction.idt file in the “MSI — Task Scheduler” folder. This is a tab delimited text file
that contains the command line to send to the schtasks.exe program (available on Windows
systems for configuring a scheduled task from the command line). The CustomAction.idt file can be
opened in any text editor, such as Notepad. The file contains a header describing the MSI
CustomAction table, and has the following columns:

o Action — A unique name for the Custom Action to be performed, this should be
“ScheduleTask”. No other names should be added or edited in this file.

o Type — This indicates the Custom Action type for the MSI. The “ScheduleTask” line the
value must always be 98.

o Source — This indicates the starting directory, which should always be INSTALLDIR.

o Target — This is the string that will be executed by the system. Edit this value if non-default
settings are required.

4. Create the ScheduleTask in the CustomAction.idt file. The default is:

ScheduleTask 98 INSTALLDIR "[SCHTASKSLOC]" /Create /SC Weekly /TR
"\"[INSTALLDIR][EXENAME]\" /jobmode" /D Sat /ST 23:00:00 /TN IdentityFinder /RU "NT

O
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AUTHORITY\SYSTEM"

Each part of the command line can be described as follows:

a. The first 3 columns (tab separated) of “ScheduleTask 98 INSTALLDIR” do not ever
change and should be left alone. The last column contains the command line to be
executed during installation.

b. The “[SCHTASKSLOCT]” is a dynamic property (variable) that is set by the MSI installer once
it finds the system location of the schtasks.exe program. This should not be changed.

c. The “/Create” means that schtasks.exe should create a task.

a. The “/D Sat /ST 23:00:00” describes the schedule. This translates to: Run the task daily
every Saturday at 11pm local time. To view all the different time scheduling options, open a
command prompt by clicking Start - Run, typing “cmd” without quotes, and pressing Enter.
Then type

schtasks /Create /7

d. The /TR "\"[INSTALLDIR][EXENAME]\" /jobmode" describes the command line that the task
scheduler will run. The quotes in this part of the command are extremely important. If paths
and arguments are not properly quoted, the task may be created but will never run. The /TR
switch indicates to schtasks.exe that the following command line should be run and is
followed by a space and then the open quote “ character. The entire command line is
contained within “* quote characters (the last one is after /jobmode). However, quotes are
also needed around the full path to the Identity Finder executable, so the backslash \
character is used before any quotes to ensure that they are escaped and added to the task
scheduler’s definition. In the case above, Identity Finder would be run from its installation
location with the switch /jobmode. If a default install is performed, this would create a task
with the following command line:

“C:\Program Files\Identity Finder 4\ldentityFinder.exe” /jobmode

If an ini file is desired and, for example, it is in a network location, that information must also
be quoted. The line in the CustomAction.idt should read:

ScheduleTask 98 INSTALLDIR "[SCHTASKSLOC]" /Create /SC Weekly /TR
"\"[INSTALLDIR][EXENAME]\" /jobmode /inifile=\"\\NetworkServer\ShareName\IDF.ini\"" /D
Sat /ST 23:00:00 /TN IdentityFinder /RU "NT AUTHORITY\SYSTEM"

e. The /TN IdentityFinder names the task in the Scheduled Tasks folder on the computer. This
name can be anything as long as it doesn’t contain special characters; however, there is
little reason to ever change this value.

f. The last components of the line are the user credentials. By default the task is scheduled as
the local system account by /RU “NT AUTHORITY\SYSTEM?”; however, any user account
and credentials may be used. The syntax is /RU “DOMAIN\USER” /RP “PASSWORD”. For
example, if a default configuration was desired but a service account with the domain
“IdentityFinder” and user name of “IDF_Service”, and a password of “Id3ntity1!”, the
CustomAction.idt line would change to:

ScheduleTask 98 INSTALLDIR "[SCHTASKSLOC]" /Create /SC Weekly /TR
"\"[INSTALLDIR][EXENAME]\" /jobmode" /D Sat /ST 23:00:00 /TN IdentityFinder /RU
"IdentityFinden\IDF_Service" /RP “Id3ntity1!”

5. Import the updates into the MSI. The MSI can be obtained as the output of adding a license file to
the installer as described above in Using a Batch Script to Add a License File or Manually Adding a
License File, or by extracting the MSI manually as described in Manually Extracting the MSI.

O
identity Copyright © 2008 Identity Finder, LLC Xy




22

a. Right click on the MSI in Windows Explorer and choose “Edit in Orca”. Alternatively, open

Orca and go to the File > Open menu and locate the MSI.

b. Select the Tables - Import Tables menu:

—~* IdentityFinderEnterpriseSetup.msi - DFca
Fil= Edit | Tables Tramsform Tools  Yiew  Help

=10l %]

& E’vl add Table. .. Chrl+T b : T,
———- Add Custom Table... J H
Tahles Drop Table... | Diescription I Ti=
ActionT 2., Publishing ... F
i add R, . Ckr|+R i .g
AdrninE . Publishing ...
[ram Rowis)
Adrninl. 8., Computing...
AclytEs Export Tables. .. || validating i...
apncie: I veldzsio, Cormputing. ..
Binary adjust Schema. .. ... Creating sh... Sk
ChieckBo Createfo... Creating fo... Fo
[=Tanimit=] R arme i, LY x
corgerare | i
Tables: 39 |I|Nu:. column is selected, S

c. Navigate to the folder “MSI - Task Scheduler” included in the zip file that contained this

documentation, and where CustomAction.idt file was edited, to see the following:

Look jr: | 79 M5 - Task Scheduler

My Documents

.

by Computer

<@
Py et
Pl

=2 Q22 E

2%

Registry.idt

File name:

Files of twpe:

=liAppSearch.idt
Cornponent.idt
Cuskormaction. idt
CrLocakar.idr

FeatureComponents.idt
InstalExecuteSequence.idt

Signature, idt

10T files [.idt)

Open

Cancel

It
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d. Select all of the files by using the mouse to drag a selection box over all files, or hold down
the CTRL key and hit A (CTRL + A):

Deszktop

4

by Documents

™

by Computer

open 21|
Lok ire | (3 MSI - Task Scheduler = © F -
_ampo 1L, 100
omackion.idk
File name: I".-'l'-.ppSearch.idt" "Component.idt" "Eustu:-m-’-‘-.u:tinj Open I
Filez af type: IIDT files [*.idt) j Cancel |
P

e. Click the “Open” button to obtain the Import summary dialog:

mport x|

Table | sction | | ok, |
AppSearch berge

Component Merge Canicel |
Custordction kerge

DL ocatar Irpart Erowse,. |
FeatureComponents berge —

InztallE #ecuteSequence Merge

R egiztny kerge

Signature kerge

€ Import
" Beplace
) Wenge
= Skip

f. Click OK to import all of the changes into the MSI.

identityfinder
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g. Save the MSI by using the menu File > Save:
~# IdentityFinderEnterpriseSetup.msi - O =10 x|
File Edit Tables Transform Tools Wiew Help

T Chrl4-1 IH ol
Qper. .. Chrl+i ==

Save As... [Syste...
Saye Transformed &s, .,
Close

1 IdentityFinderEnterpriseSetup, msi
2 IdentityFinderEnterpriseSetup. msi
3 IdentityFinderEnterpriseSetup. msi
4 IdentityFinderEnterpriseSetup, msi

Exit

Tables: 39 |E|N|:| column is selected, S

h. Exit Orca and test the MSI.

s
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Installing the Identity Finder Endpoint Service

Description: This section describes how to install the Identity Finder Endpoint Service. By default the
Identity Finder Endpoint Service is not installed. This component is required for interaction between the
Identity Finder Client and the Identity Finder Management Console. There are two settings relating to
the installation of the Endpoint Service that allow users to install the service with or without the service
showing up in the feature list in the graphical installation mode. It is also possible to install the Endpoint
Service executable files without registering the Endpoint Service with the operating system. This
configuration is available only for customers who are using the Management Console for reporting only,
who do not wish to register a service with the operating system.

Enable Endpoint Service Installation

Description: The steps that follow describe how to enable the Endpoint Service installation, which
registers the service with the operating system and sets it to start automatically. This service runs as
LocalSystem and is used for management of Identity Finder clients. In order for installation to succeed
and the service to start, the Endpoint Service configuration in the registry must either be configured by
the customized MSI, or it must exist on the system prior to installation. Please refer to the Management
Console documentation for information regarding the required registry settings for the Endpoint Service.

1. To enable the installation of the Identity Finder Endpoint Service, perform the following steps:
a. Locate the MSI package file. The MSI can be obtained as the output of adding a license file
to the installer as described above in Using a Batch Script to Add a License File or Manually
Adding a License File, or by extracting the MSI manually as described in Manually
Extracting the MSI.

b. Right click on the MSI in Windows Explorer and choose “Edit in Orca”. Alternatively, open
Orca and go to the File & Open menu and locate the MSI.

c. Select the Property table.

d. Find the “INSTALLIDFSERVICE” property row.

O
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e. Inthe Value column for the “INSTALLIDFSERVICE” property row, change the default value
from O to 1:

~# IdentityFinderEnterpriseSetup.msi - Orca - |EI|£|

File Edit Tables Transform Tools Wiew Help

D[ & || %|w=e ==

Tables |;| Froperty | Value |;|

Media Majorversion 4
MsiFileHash SmnarkProductVersion 4.0
Property Fourthersion 0 J
RadioButton HELMReqgistryLocation SoftwareiIdentity FinderiIdentity Finder 4 Te. ..
Reglocator HKCUR eqistryLocakion Software)Identity FinderiIdentity Finder 4 Te. ..
Registry IMSTALLIDFSERVICE 1 |
RernoveFile SHOWIDFSERVYICEFEATURE 1]
ServiceControl ALLUSERSRADIO i1
Servicelnstall DiskPrompk Identity Finder Inskallakion [1]
Shorteut ;I DefaultUIFont WixUI_Font_Mormal ;I

Tables: 41 |F'r|:||:|ert~;.f - 47 rows |'-.-'a|ue - Localizable[0] ‘,ﬁ

f. Toinstall the Endpoint Service automatically, without providing the user an option to turn the
feature off, continue to step (h) below.

g. To enable the Endpoint Service feature to be displayed in the Feature List available in the
graphical installation of Identity Finder, select the “SHOWIDFSERVICEFEATURE” property
row and change the Value column from O to 1:

—* IdentityFinderEnterpriseSetup.msi - Orca - |I:I|£|

File Edit Tables Tramsform Tools  Wiew  Help

D[] & || @5 %#(=e ==

Tables |;| Property | Value |;|

Media Majariersion 4
MsiFileHash SrnarkProductiersion 4.0
Property Fourthversion 0 J
RadioButton HKLMR.eqgistryLocation Software)Identity FinderiIdentity Finder 4 Te. ..
Reglocator HECIReqistryLocakion SoftwareiIdentity FinderiIdentity Finder 4 Te. ..
Reqgistry INSTALLIDFSERYICE 1
RemoveFile SHOWIDFSERVICEFEATURE |
ServiceConkrol ALLUSERSRADIC i
Servicelnstall DiskPrompk Identity Finder Installation [1]
Shiortcuk j DefaultUIFank Wil JI_Fonk_Marrmal ;I

Tables: 41 |Property - 47 rows [value: - Localizable[0] 4

NOTE: If the “SHOWIDFSERVICEFEATURE” is set to 1, and the user is allowed to perform
a graphical installation of Identity Finder, they can click the Custom button and they will have
the ability to enable or disable installation of the Endpoint Service. When this setting is
configured, the default install state is governed by the “INSTALLIDFSERVICE” property

s
identity Copyright © 2008 Identity Finder, LLC Xy




27

discussed above in step (e). Setting “INSTALLIDFSERVICE” to 0 will have the feature
disabled for installation by default, and a 1 means that by default the feature will be included
in installation.

h. Save the MSI by using the menu File > Save:

—#* IdentityFinderEnterpriseSetup.ms =10 x|
IE Edit Tables Transform Tools Wiew Help

T Chrl+M IH o

Qper. .. Chrl+i

Save Chrl+5 I [Path  [De..|

Save As... | [Syste...
Saye Transformed &s, .,
Close

1 IdentitvFinderEnterpriseSetup. msi
2 IdentityFinderEnterpriseSetup. msi
3 IdentityFinderEnterpriseSetup, msi
4 IdentityFinderEnterpriseSetup, msi

Exit

Tables: 39 |E|N|:| column is selected, S

i. Exit Orca and test the MSI.

Install Only Endpoint Application Files

Description: The steps that follow describe how to install only the Endpoint Service application files.
These steps will ensure that the service is not registered with the operating system. When the
installation is configured in this manner the Identity Finder Client can only send data to the
Management Console for reporting purposes only.

NOTE: Disabling service registration will prevent Identity Finder from doing anything except sending
results to the Management Console for reporting functionality only. When the MSI is edited in this
manner, users cannot upgrade the MSI using an MSI directly from the Identity Finder web site. Thus it
is highly recommended that if these options are used, the MSI contains settings that prevent Auto
Update functionality from ever executing in the Identity Finder Client software. Please consult the
Administrators Guide for a list of settings and a description of the Auto Update settings. In order for
users who install with the edits listed below to upgrade, the administrator distributing the installation
package must download the new MSI from the Identity Finder web site and re-apply all edits to the MSI
before pushing it out as an upgrade. Performing these edits and subsequently requiring an update is
the sole responsibility of the party editing the MSI package, and is not supported by Identity Finder.

1. Toinstall only the Endpoint Service application files requires all service specific configurations to be
removed from the MSI, and the actual service application files must be re-assigned to another
installation component. To accomplish this, perform the following steps:

a. Locate the MSI package file. The MSI can be obtained as the output of adding a license file
to the installer as described above in Using a Batch Script to Add a License File or Manually
Adding a License File, or by extracting the MSI manually as described in Manually
Extracting the MSI.

O
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Right click on the MSI in Windows Explorer and choose “Edit in Orca”. Alternatively, open
Orca and go to the File > Open menu and locate the MSI.

Select the File table.

Locate the row where the File column has the value “IDFSEPDLL” and change the
“Component_” column value from “IDFService” to “MainExecutable”. Perform the same

change for the row with the File column value “IDFSEPEXE”. When complete, these two
rows should look as follows in the File table:

~#* IdentityFinderEnterpriseSetup.msi - Orca

File Edit Tables Transform

Tools

Wiew  Help

=10l x|

s == I S E RS

EEHEEE

identity

Tables |+l| File | Component_ | FileMame | File... | Ver... | La... | A..I 5. |;|
H_I IDFHELP MainExecutable  idf.chm|IdentityFinder.chm | 11955333 512 4
Icon IDFDLL MainExecutable  idf. dll| IdentityFinder. dll 434176 2.6.0.8 1033 512 &
Install. .. IDFHDLL MainExecutable  idfhelp.dil|idfhelp,dil 1045123 6.3.4.0 1033 512 A
Install. .. J IDFROLL MainExecutable  idfreprt.dlljidfrepaort. dll 214016 1,22, 1033,7 512 7
Launc... IDFSHOLL  MainExecutable idfshesxt.dll|idfshesxt. dil 102400 1.0.0.0 1033 512 &
ListBiorx: IDFSEPDLL  (MainExecutable E m
Media ﬂ (NS S [ ainEecutable  |idFEp. exe|idfEndpoint.exe 1,0.0.0 m 10 |y
Tables: 41 |File: - 100 rows [File: - Strina[72], Key 4
Go to the Component table and remove the row where the Component column value is
“IDFService”. To remove the row, first highlight the row by clicking on it, and then selecting
the menu Tables = Drop Row(s), and answer “OK” to the warning message that follows:
~ ¥ IdentityFinderEnterpriseSetup.msi - Orca O] x|
File Edit Im Transform  Tools  Wiew Help
B | E’hll add Table. .. Chel+T El m o
&dd Custom Table. ..
Tables  Drop Table... I | Componentld | Direct... | AI Condition | KeyPath |
add Row, kR {EFE13733-DDZ.., INSTALLDIR 4 hkcukeyCE. ..
Condition IR {FFIC3FD1-234... INSTALLDIR 4 MOT ALLUSERS deskkopkey
Conkrol Export Tables. . ers {FFIE0ZAB-AD4... INSTALLDIR. 4 ALLUSERS desktopk eyl
ControlC Import Tables... {C114CE50-C45,,, INSTALLDIR 4 hkcufa
ConkralE =T — {E9SAESDA-BBE, .. [INSTALLDIR. ﬂ_ IDFSEPEXE
CreateFamer———"" {DAAS1Z27E-242,,, INSTALLDIR O APPEXE
Customaction MainHKCUIbemns {A534384C-11E... INSTALLDIR 4 hkcukey
Dialog fMainHELMIEems {04AF9560-7AZ, ., INSTALLDIR 4 hiklrnkey
Direckary ShelExtensionRegiskey {CAZRZZ18-816, ., IMNSTALLDIR 4 shelregl
Errar StartShortcuts {Z7ACEBAB-817... INSTALLDIR 4 MNOT ALLUSERS uninstkey
EventMapping StartShortoutspllsers J06580579-FESG, .. INSTALLDIR. 4 ALLUSERS uninskkeyal
Feature ;I
Tables: 41 |C|:|m|:u:|nent - 11 rows Component - Skring[72], Kew v
e —
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f. Several rows in other tables will need to be removed (dropped) as well. Follow step (e)
above for the following table rows:

i. Feature table, the row where the Feature column value is “IDFServicelnstall”.

ii. FeatureComponents table, the row where the “Feature_” column value is
“IDFServicelnstall”.
iii. CustomAction table, the row where the “Action” column has the value
“RemoveServiceFeature”.

iv. InstallUlSequence table, the row where the “Action” column has the value

“‘RemoveServiceFeature”.
v. Condition table, all rows where the “Feature_” column has the value
“IDFServicelnstall’. There should be 2 total rows where the “Feature_” column has
the value “IDFServicelnstall”.

g. Find the table ServiceControl and click on it to select it, then go to the Tables - Drop Table

menu, and answer Yes to the warning dialog:

—~* IdentityFinderEnterpriseSetup.msi - Drca
Fil= Edit | Tables Tramsform Tools  Wiew Help

=10l x|

Ol 2l Add Table... Crl+T El m T,
———- fdd Custom Table...

Tables EEREH IECuntruI | MName | Ev... | Argume... | W| Compone... |
Rernovel add Row, CHl+R £ yice IDFERdpaink 163 1 IDFService
ServiceC|  Drop Rowis)

Servicel Export Tables. ..
Shortcut Import Tables. ..
Signat
anatur adjust Schema. ..
TextSkvle
LI Texk LI |
Tables: 41 [ServiceConkral - 1 row M calumn is selected, o
h. Find the Servicelnstall table and click on it to select it, then go to the Tables - Drop Table
menu, and answer Yes to the warning dialog:
—~* TdentityFinderEnterpriseSetup.msi - Drca - |EI|5|

Fil= Edit | Tables Tramsform Tools  Wiew Help

nl=l #dd Table. .. Chrl4-T | | BB
————- fAdd Custom Table..,

LGN Orop Table. .. Na... | Dis...| St:r...| Sta... | Err... | Lo... | De... | Sta... | Pa.
Removel 4 ipo Chl+R IDFE... Identi... 16 2 32768 Local,..
Servicelll  Drop Rowis)

Shortcut Export Tables. ..
signatur Import Tables.. .
TextStyl adjust Schema. ..
ITexk =
Uparade hd| K1 | |
Tables: 40 [Servicelnskall - 1 row M calumn is selected, o
O
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i. Save the MSI by using the menu File > Save:
~# IdentityFinderEnterpriseSetup.msi - O =10 x|
File Edit Tables Transform Tools Wiew Help

T Chrl4-1 IH ol
Qper. .. Chrl+i ==

Save As... [Syste...
Saye Transformed &s, .,
Close

1 IdentityFinderEnterpriseSetup, msi
2 IdentityFinderEnterpriseSetup. msi
3 IdentityFinderEnterpriseSetup. msi
4 IdentityFinderEnterpriseSetup, msi

Exit

Tables: 39 |E|N|:| column is selected, S

j. Exit Orca and test the MSI.

s
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Customizing the Installation Experience

Description: This section describes the customization of the MSI to alter the user experience at
installation. There are edits that may be made from a command line launch of the MSI or within the

MSI itself to change the options available to the user during a graphical installation or control the events
that occur at the end of any installation, such as the launching of Identity Finder.

NOTE: These installer customizations are only available with the installer provided with Identity Finder

Enterprise Edition v3.5 and above. Configuring these settings on older installers can break the

installation or cause unintended results.

1. To add a property to the Property Table within the MSI:
a. Locate the MSI package file. The MSI can be obtained as the output of adding a license file
to the installer as described above in Using a Batch Script to Add a License File or Manually

Adding a License File, or by extracting the MSI manually as described in Manually

Extracting the MSI.

b. Right click on the MSI in Windows Explorer and choose “Edit in Orca”. Alternatively, open
Orca and go to the File > Open menu and locate the MSI.

c. Select the “Property” table, to display the contents of the Property table:

~#* IdentityFinderEnterpriseSetup.msi - Orca
File Edit Tables

Transform  Tools

Wiew  Help

=10l x|

D E| & Bz #l=e] =z

| -

Tables |;| Froperty | Yalue
ListBiox Manufackurer Identity Finder, LLC
Media ProductCode {9833A605-5683-4BED-8F 28-35FEACBGT 302
MsiFileHash ProductLanguage 1033
Property ProduckMarme Identity Finder
RadioButton Produckyersion 4.0.0
ReqglLaocatar UpgradeCode {ZF7EOD4D-FEEZ-4B40-A02 C-624 75287 30FE};
Reqistry ALLLISERS 2
RemoveFile EXEMNAME IdentityFinder . exe
ServiceConkrol Shortapphlane Identity Finder
Servicelnstall Majoriersion 4
Shorkcut SrnarkProductVersion 4.0
Signature Fourthersion 0
Textskyle _I HkLMReqgistryLocation | SoftwareIdentity Finder\Identity Finder 4 Te...
-
Lo e S P P o S SO S N o S PO S S
Tables: 41 [Property - 47 rows Mo colurnn is selected.

[
/4
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d. Add a new property by choosing the menu Tables - Add Row:

—~* IdentityFinderEnterpriseSetup.msi - Drca
File Edit | Tables Tramsform  Tools  Wiew  Help

=10l x|

m=l Add Table... Crl+T El m T,
———- fdd Custom Table...
Tables Drop Table. .. I| Value |ﬂ
ListBio: Add Row, . ChIHR. Idenkity Finder, LLC
Media Drop Row(s) {95334605-5653-4BED-GF25-35FEGCBAT 30 2T
MsiFileH: . 1033
BEEUS  Import Tables... Identity Finder
F.adioBul 4.0.0
adietd adjust Schema. ..
Reqglocarm J-l (8 = s {ZF7EOD4D-FSEZ2-4B40-A02 C-624 75287 30FE}; _I
- -
Tables: 41 |Property - 47 rows e calumn is selecked, o

e. The Add Row dialog box will be displayed showing the options for completing the Property

and Value fields:

x

Mame | W alle |
(EJ Froperty
"W alue
— Colurmn
Froperty - String[72], Reguired
|

k. I Cancel

identityfinder Copyright © 2008 Identity Finder, LLC
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f. Enter the appropriate property name and value. For example, to disable removal of user
settings in all cases when an uninstall occurs, set FULLCLEANUP to O:

x|

Mame Walue
T Froperty | FULLCLEAR P
"W alue 1]
— Colurmn
Froperty - String[72], Reguired
FULLCLEAMUP

k. I Cancel

g. Repeat steps (a) through (g) for all desired properties.

h. Save the MSI by using the menu File > Save:

—~* IdentityFinderEnterpriseSetup.msi - [ - | I:Ilﬂ
File Edit Tables Transform Tools Wiew Help
Nz Chrl+ IH =

Qper. .. Chrl+i

Save

Save As... [Syste...
Saye Transformed &s, .,

Close

1 IdentityFinderEnterpriseSetup, msi
2 IdentityFinderEnterpriseSetup. msi
3 IdentityFinderEnterpriseSetup. msi
4 IdentityFinderEnterpriseSetup, msi

Exit

Tables: 39 |E|N|:| column is selected, S

2. To edit an existing property in the Property Table, follow these steps:
a. Follow steps (1a) through (1c) above to open the MSI and display the property table.

b. Select the property to edit and click on the Value column to edit the Value. For example, to
uncheck the Launch Identity Finder checkbox on the last page of the installer, set the

s
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LAUNCHPRODUCT property to O:

—~* IdentityFinderEnterpriseSetup.msi - Drca ;lglﬁl
File Edit Tables Tramsform Tools  Wiew Help
D@ & [s|em] #{=e] =z
Tables |;| Property |'1.r'alua | =
ListBiox WixlJI_WerifvReady... CustomizeDlg
Media Wi UI_WerifyReady,.. SetupTypeDlg
MsiFileHash WixlJI_Mainkenance... MaintenanceTypellg
Property WixUI_Mainkenance. .. CuskomizeDlg
RadioButton WixUI_Maintenance. .. YerifyReadyDlg
Reglocator WixlJI_Maintenance... VerifvReadyDlg
Reqistry WixUI_Maintenance... Maintenance'welcomeDlg
RemoveFile ErrorDialog ErrorDlg
ServiceContral LAUNCHPRODUCT |]|
Servicelnstall Thgres Mo
Shorteut WixUIRMOption UseRM
Signature J SecureCustormnProp...  MEWERFOUMNDREQUIREUPDATE ; SAMEFCLIMND
- -
Tables: 41 |Property - 47 rows [value: - Localizable[0] 4

c. Repeat steps (a) through (b) above to edit as many properties as desired.

d. Save the MSI by using the menu File > Save:

~ ¥ IdentityFinderEnterprisesetup.msi - =100 x|
IE Edit Tables Transform Tools Wiew Help
Tt CErl+M Imf 2,
CIpen Chel+0
Sav ChrS I |Path | De..|
Save bs... [Syste...
Save Transhormed As, ..
Close
1 IdentityFinderEnterpriseSetup, msi
Z IdentityFinderEnterpriseSetup, msi
3 IdentityFinderEnterpriseSetup, msi
4 IdentityFinderEnterpriseSetup. msi
Exit
Tables: 39 It [Mo calumn is selected. =

3. To add a property to the command line execution of the MSI, follow these steps:

a. Locate the MSI package file. The MSI can be obtained as the output of adding a license file
to the installer as described above in Using a Batch Script to Add a License File or Manually

Adding a License File, or by extracting the MSI manually as described in Manually

Extracting the MSI.

b. Open a command prompt by clicking Start = Run, typing “cmd” without quotes, and pressing

Enter.

identity
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c. Inthe command window use the “cd” command to navigate to the directory containing the
MSI.

d. Launch the MSI using msiexec as follows with desired property=value pairs:
msiexec /i IdentityFinder4Setup.msi PROPERTY1=VALUE1 PROPERTY2=VALUE2

For example, to force user settings to be removed on uninstall, issue the install with the
following command line:

msiexec /i IdentityFinder4Setup.msi FULLCLEANUP=1

The following sub-sections list the different options available for customizing the MSI.

Typical and Custom Installation Options

Description: The graphical installation of Identity Finder has two basic installation options: Typical and
Custom. In the Typical mode, the default settings are used to install Identity Finder and users are not
shown any of the available features. In Custom mode, users are shown the feature tree displaying the
components of the Identity Finder installation and can select or deselect each component.

Either the Typical or Custom installation option can be disabled, but not both. If both are disabled, the
Typical option will still be available, otherwise the user would not be able to install Identity Finder.

To disable the Typical installation option, use the following property:
Property Name: DISABLETYPICALINSTALL
Property Value: 1

To Disable the Custom installation option, use the following property:
Property Name: DISABLECUSTOMINSTALL
Property Value: 1

Per-User or Per-Machine Installations

Description: Starting with Identity Finder Enterprise version 3.5, all installations are Per-Computer
installations by default. All prior versions defaulted to Per-User installations. It is possible to change
the default install type and to force the setting on the user and not allow them to change the setting.

To change the default installation type, use the following property:
Property Name: ALLUSERS
Property Values:
e 0 - This value will force a per-computer installation. If the installer does not have rights to install
a per-machine application, the install will fail.
1 — This value will force a per-user installation.
e 2 —This is the default value. This value will allow the installer to determine whether or not it can
install the application on a per-computer basis, and if it can not, it will install per-user only.

For more information about how the ALLUSERS property works, please reference the ALLUSERS
property in the Microsoft Windows Installer MSDN Documentation:
http://msdn.microsoft.com/en-us/library/aa367559(VS.85).aspx

O
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To prevent users from being able to change the Per-User or Per-Computer installation type on a
graphical install, use the following property:

Property Name: DISABLEAUOPTION

Property Value: 1

Launching Identity Finder After Installation

Description: It is possible to launch Identity Finder after an installation and it is also possible to force
this to happen in both graphical and non-graphical installation modes. This allows the launch of Identity
Finder regardless of how an MSI package is installed and it can occur with a custom command line that
could, for example, kick off a search from within Identity Finder.

By default when a graphical installation ends the user is shown a checkbox that is checked with the
option to launch Identity Finder. To change the default so that the checkbox is unchecked, but not
disabled, change the following property:

Property Name: LAUNCHPRODUCT

Property Value: 0

To force Identity Finder to be launched upon completion of the installer, set the following property:
Property Name: LAUNCHONEXIT
Property Value: 1

To change the launch command, edit the CustomAction table in the MSI:
1. Right click on the MSI in Windows Explorer and choose “Edit in Orca”. Alternatively, open Orca and
go to the File > Open menu and locate the MSI.

2. Select the “Custom Action” table, locate the “LaunchFile” row, and click on the Target column:

—~ ¥ IdentityFinderEnterpriseSetup.msi - Orca =10l =]
File Edit Tables Transform Tools Wiew Help
D& &2 %= ==
Tables «1 | Action | T... | Source Target I Al
w ClearFLULLCLEANUP 51 FULLCLEANUP {t
Dialog SetFULLCLEAMLP 51 FULLCLEAMUP 1 J
Direckary: J ResetReqFilesRemoyvel ocakion RegFilesRemovelocation  [RegFolderloc]
error M |
EventMapping Askllser ToRemoveSettings 1 MSIDLL RemovellserSetti. ..
Feature MoDowngrade 19 A laker wersion of,.,
FeatureCom, .. ll Setal 51 ALLUSERS 1 ll
Tables: 41 |Cust|:|m.ﬁ.|:ti|:|n - 29 rows |Target - Skring[255], Mullable i

3. Add the desired Identity Finder command line parameters. The command line parameters are
described in the on-line help, the help included with the installation, and the Administrator’s Guide.

identity
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For example, the /jobmode switch may be added to the Target column:
—* IdentityFinderEnterpriseSetup.msi - Orca - | I:Ilﬂ

File Edit Tables Tramsform Tools  Wiew  Help

D (& &R =2 ==

Tables ~1 | Action |T |Suur[:t: |Targﬂt I =
ClearFULLCLEAMUP 51 FULLCLEAMUP i

Dialog SetFULLCLEAMUP 51 FULLCLEARMUP 1 J

Direckory J ResetRegFllesRemweLDcatlun RegFilesRemovelocation [RegFolderloc]

cror P S ey pe fobmode] |

EventMapping AskUserToRemoveSetkings 1 MSIDLL Removellseraetti, .,

Feature MoDowngrade 19 A later version of ...

FeatureCam, ., j Setall 51 ALLUSERS 1 j
Tables: 41 [Customaction - 29 rows [Target - String[255], Mullable oz

4. Save the MSI by using the menu File > Save:
~# IdentityFinderEnterpriseSetup.msi - =10 x|
File Edit Tables Transform Tools Wiew Help

Mew Chrl+h I i
Qper. .. Chrl+i

| Path | De... |

Save As... [Syste...
Saye Transformed &s, .,

Close

1 IdentitvFinderEnterpriseSetup. msi
2 IdentityFinderEnterpriseSetup. msi
3 IdentityFinderEnterpriseSetup, msi
4 IdentityFinderEnterpriseSetup, msi

Exit

Tables: 39 [N column s selected. -

Optional Removal of User Settings on Uninstall

Description: The installer will provide the user with an option to remove user settings upon any
uninstall attempt except a silent (no graphical interface) uninstall. This option may be suppressed to
prevent the user from making this choice.

NOTE: Even if the installer “removes user settings” the installer only has access to the currently logged
on user who is executing the uninstall operation. It is not possible to remove all settings for all users.
In most cases the install/uninstall is done from the same user account, making these options relevant.

To disable providing the user an option for removal of user settings, set the following property:
Property Name: FULLCLEANUP
Property Values:

e 0 - This value will force user settings to be saved during uninstall.

e 1 —This value will force user settings to be removed during uninstall (this is a clean uninstall).

s
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Force a Non-Graphical Installation of Identity Finder

Description: By default the installer will be run with a graphical interface unless it is launched in a
manner that suppresses the graphical interface. It is possible to force the graphical interface by
settings a few properties in the MSI.

To suppress the user interface both of the properties below must be set:

Property Name: LIMITUI
Property Value: 1

Property Name: ARPNOMODIFY
Property Value: 1

Configuring the LIMITUI property returns the installation level to Basic. During a Basic installation the
MSI installs with a progress bar only. The user is able to cancel the installation only, but is not able to
modify any installation options. The ARPNOMODIFY property ensures that when the user opens the
Add/Remove Programs Control Panel, the Identity Finder package will not display the “Change” option,
since the user is not allowed to change any of the installation options when the MSI is run with an
installation level of Basic.

NOTE: These properties should only be set if the MSI package is unable to be deployed in a manner
where the Ul level can be set to any of the options available within the Windows Installer and a non-
interactive installation is required. Most deployment tools, including Active Directory, provide standard
Windows Installer options for invoking the installation, including allowing a silent install or setting the
exact Ul level. Generally, the options listed above would only be used if users are downloading the
MSI themselves from a centralized location, or are installing the package manually from installation
media, such as a CD or USB key.

O
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Advanced Installation Parameters

Description: The MSI package can be launched and operated in a variety of different modes with
options provided by the Microsoft Installer. Options such as silent installs and uninstalls are possible by
sending custom command line parameters to the Microsoft Installer. These options can be integrated
into any already existing deployment software to help ensure that the MSl is installed exactly as each
organization requires.

To perform a silent installation:

1. Locate the MSI package file. The MSI can be obtained as the output of adding a license file to the
installer as described above in Using a Batch Script to Add a License File or Manually Adding a
License File, or by extracting the MSI manually as described in Manually Extracting the MSI.

2. Open a command prompt by clicking Start - Run, typing “cmd” without quotes, and pressing Enter.
3. Use the “cd” command to navigate to the directory containing the MSI.

4. Execute the following command line:

msiexec /i IdentityFinder4Setup.msi /qgn

5. The above command line can be added to any deployment software that distributes the MSI. The
/gn switch means that the Windows Installer should install the package without a graphical
interface. To obtain all of the command line options, type the following at a command prompt:

msiexec /?

Alternatively, the Windows Installer Command Line Options documentation is available online
through the Windows Installer reference documentation on MSDN:
http://msdn.microsoft.com/en-us/library/aa367988.aspx

O
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Troubleshooting

Description: The Windows Installer is incredibly complex, and one typographical error can cause the
installation to break with cryptic error messages. The Windows Installer does provide several different
logging options that can help developers determine why an installation is failing. These steps should
be followed before contacting the Identity Finder Support Team, as the information obtained from
executing these steps is required by the support team in order to help solve the problem.

Generate a Windows Installer Log File

Description: Generating a log file is always the first step in troubleshooting a Windows Installer
package failure. In general, regular logging will contain all of the relevant information required to
troubleshoot. In the rare instance where more information is required, a verbose debugging logging
option is available.

Generating a log file requires the MSI package to be invoked manually using the Windows Installer

from the command line:

1. Locate the MSI package file. The MSI can be obtained as the output of adding a license file to the
installer as described above in Using a Batch Script to Add a License File or Manually Adding a
License File, or by extracting the MSI manually as described in Manually Extracting the MSI.

2. Open a command prompt by clicking Start > Run, typing “cmd” without quotes, and pressing Enter.
3. Use the “cd” command to navigate to the directory containing the MSI.

4. Execute the following command line:

msiexec /1 IdentityFinder4Setup.msi /1* msi-log.txt

5. Execute the installer in whatever method produces an error and exit the installer. The “msi-log.txt”
file will be created in the same directory the MSI is located and will contain all of the relevant error
information. Reading through the log will show the specific error code. In most cases, entering the
code and error message into Google’s search engine (http://www.google.com) will provide enough
relevant information to solve the problem.

6. If an Internet search does not provide enough information, contact support@identityfinder.com and
be sure to provide detailed steps to allow the support team to reproduce the error, along with the
msi-log.txt file attached to your email. If the MSI has been edited beyond the automated addition of
the license file, also attach the relevant table exports, detailed in the next section, to your email.

Exporting an Edited MSI Table

Description: Often, an MSI will break because of an errant entry in an edited table. If an MSI stops
working, exporting the tables that have been edited along with the log file above provide crucial
information that can be used to help identify the problem. The Identity Finder Support Team will have
trouble helping you and will likely request this information if you have edited the MSI manually, so
exporting these tables and attaching them along with a log file in your initial support email will provide
the quickest resolution.

Generating a log file requires the MSI package to be invoked manually using the Windows Installer
from the command line:

O
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1. Locate the MSI package file. The MSI can be obtained as the output of adding a license file to the
installer as described above in Using a Batch Script to Add a License File or Manually Adding a
License File, or by extracting the MSI manually as described in Manually Extracting the MSI.

2. Right click on the MSI in Windows Explorer and choose “Edit in Orca”. Alternatively, open Orca and
go to the File > Open menu and locate the MSI.

3. Choose the Tables > Export Tables menu option:

—~ & IdentityFinderEnterpriseSetup.msi ;|g| il
File Edit | Tables Tramsform  Tools  Wiew Help
] Add Table. .. Chrl+T oo
E &dd Cuskom Table. .. bJ H =i
Tables Drop Table. .. I Yalue ﬂ
MziFileH . Custornizelig
Add Row. .. Ckrl+R.

Drop Raw(s) . SetupTypellg
RadioBL MaintenanceTym
Poele  Export Tables... . CustomizeDig
Registr Import Tables... . werifyReadyDig
Rernove  Adjust Schema. .. . WerifyReadyOlg
Remaove. ., Wi}{U'I_MaiﬂtenaﬂceT .. Maintenanceel
Shortout ErrorDialog ErrorDlg J
SignatLre LALMNCHPRODLICT 0
TextStyle Isgree Mo _lj
urrext x| [4] I b

Tahles: 39 |Propert |Walue - Localizable[0] 4

4. Choose an output directory and check all of the tables that have been manually edited. For
example, if only registry settings were added, export the Registry table to a specified directory, such
as C:\IDFSupport:

Export Tables x|

Catput Directorny:

IE: 4 DFSuppart Browse... |

¥ Use Long File Mames.

T ables:

a|  Selectal |
Clear Al |
Ireeert |

[|RemoveRegisty
1S hortcut j

s
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5. Click OK and the directory (in the example above it is C:\IDFSupport) will contain the relevant .idt
files. Inthe case above where just the Registry Table is exported, the directory will contain a
Registry.idt file.

6. Close Orca.

7. Attach all relevant .idt files in your email to support@identityfinder.com and be sure to include the
relevant log file as described in the above section Generate a Windows Installer Log File.
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